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EO Attenuator 
 

May 2016 

 

No part of this manual, including the products and 

software described in it, may be reproduced, 

transmitted, transcribed, stored in a retrieval system, 

or translated into any language in any form or by any 

means, except documentation kept by the purchaser 

for backup purpose, without the express written 

permission of Edmund Optics (hereinafter Edmund 

Optics). 

 

Product warranty or service will not be extended if: 

 

1. The product is repaired, modified or altered. Unless 

such repair, modification of alteration is authorized in 

writing by Edmund Optics. 

 

2. The serial number of the product is defaced or missing. 

 

Edmund Optics provides this manual “as is“ without 

warranty of any kind, either express or implied, 

including but not limited to the implied warranties or 

conditions of merchantability for a particular purpose. 

In no event shall Edmund Optics, its directors, 

employees or agents be liable for any indirect, special 

incidental, or cosequential damages (including 

damages for loss of profits, loss of business, loss of use 

or data, interuption of busines and the like), even if 

Edmund Optics has been advised of the possibility of 

such damages arising from any defect or error in this 

manual or product. 

 

Specifications and information contained in this 

manual are furnished for informational use only, and 

are subject to change at any time without notice, and 

should not be construed as a commitment by Edmund 

Optics. Edmund Optics assumes no responsibility or 

liability for any errors or inaccuracies that may appear 

in this manual, including the products and software 

described in it. 

 

This manual is directly connected to firmware version. 

Latest firmware, software and manual versions can be 

downloaded from www.edmundoptics.com. 

Products and corporate names appearing in this manual 

may or may not be registered trademarks or copyrights 

of their respective companies, and are used only for 

identification or explanation and to the owner’s benefit, 

without intent to infringe. 
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1. Introduction 

 

This user manual is designed to help to install and 

operate EO Attenuator. Before installing and operating 

EO Attenuator please read installation and operation 

instructions carefully. Safety instructions must be read 

carefully. If there are any questions about contents of 

this manual please contact info@edmundoptics.com. 

Edmund Optics reserves the right to update contents of 

this manual without any notification. 

 

1.1. EO Attenuator short description 

 

Compact motorized attenuator - EO Attenuator is a 

computer controlled laser beam attenuation device. It 

attenuates a free space laser beam/pulse continuously 

without introducing additional energy fluctuations. EO 

Attenuator is controlled by a computer via USB. Also it 

has “STEP/DIR INTERFACE” connector for controlling 

via other devices. 

 

1.2. General safety requirements 

 

Compact motorized attenuator is designed to operate 

in conjunction with laser systems. All applicable rules 

and regulations for safe operation of lasers must be 

known and applied while installing and operating EO 

Attenuator. The customer is solely responsible for laser 

safety while using EO Attenuator as a standalone 

device or integrated into system. The customer must 

consider protective measures. 

 

While assembling or operating EO Attenuator, do not 

stare at the direct or scattered laser light even with 

safety goggles. All parts of the body must be kept away 

from the laser radiation. While adjusting laser beam 

through EO Attenuator, laser power must be kept as 

low as possible. Hazardous laser radiation can 

increase while optical components or instruments are 

used in combination with EO Attenuator. Appropriate 

eye protection must be worn at all times. Electrical safety 

requirements must be complied while assembling and 

operating EO Attenuator. 

 

1.3. Symbols 

 

Warning! 
 

Sections marked with this symbol explain dangerous 

situations that can result as personal injury or death. 

Always read the associated information carefully, before 

performing indicated procedure. 

 

Attention! 
 

Paragraphs preceded by this symbol explain hazards 

that could damage the instrument and connected 

equipment or may cause loss of data. 

 

Note 
 

This manual also contains “NOTES” and “HINTS” written 

in this form. 

 

1.4. Regulation 

 

Attention! 
 

The following statement applies to the products covered 

in this manual, unless otherwise specified herein. The 

statement for other products will appear in the 

accompanying documentation. 

 

These limits are designed to provide reasonable 

protection against harmful interference in a residential 

installation. This equipment generates, uses, and can 

create radio frequency energy and, if not installed and 
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used in accordance with the instructions, may cause 

harmful interference with radio communications. 

However, there is no guarantee that interference will 

not occur in a particular installation. If this equipment 

causes harmful interference to radio or television 

reception, which can be determined by turning the 

equipment off and on, the user is encouraged to try to 

correct the interference by one or more of the 

following measures: 

 

 Reorient or relocate the receiving antenna. 

 

 Increase the separation between the 

equipment and receiver. 

 

 Connect the equipment into an outlet on a 

circuit different from that to which the 

receiver is connected. 

 

 Consult the dealer or an experienced 

radio/TV technician for help.  

 

Edmund Optics is not responsible for any radio or 

television interference caused by modifications of this 

equipment or the substitution or attachment of 

connecting cables and equipment other than those 

specified by Edmund Optics. The correction of 

interference caused by unauthorized modification, 

substitution or attachment will be treated as 

responsibility of the user. 

 

Attention! 
 

Cellular phones or other radio transmitters are not 

recommended to be used within the range of three 

meters of this unit since the electromagnetic field 

intensity may then exceed the maximum allowed 

disturbance values according to IEC 61326-1. 

 

1.5. Operating and storage conditions 

 

For proper EO Attenuator functioning please use the 

assigned controller (found in the same package). Using 

unassigned controllers might be harmful to the device. 

Environmental conditions that must be hold while 

storing, servicing and operating are: 

• Storage temperature should be between -25 °C and 

+60 °C. 

• Operating temperature is 25 °C ± 10 °C. 

• EO Attenuator must be protected from humidity, dust 

and corrosive vapors to avoid damaging optical 

components and electronics. 

• Avoid strong static electricity and electromagnetic 

fields. 
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2. Operation Principle 

 

EO Attenuator incorporates a rotating quartz K/2 

phase waveplate and one polarizer which separate s-

polarized and p-polarized beams (fig. 1). The intensity 

ratio of the two beams may be continuously varied 

without alteration of other beam parameters by 

rotating the waveplate. Proper functioning of EO 

Attenuator requires optimal configuration of optical 

elements regarding to incident laser beam 

polarization contrast. Higher incident laser beam 

polarization contrast leads to higher EO Attenuator 

output polarization contrast. 

 

 

3. Package contents 

 

• Compact motorized attenuator - EO Attenuator 

• Controller 

• USB cable (2m length recomended but no longer than 

3m) 

• 12V power supply  

• Software, installation instructions in USB flash 

• Polarizer – (already in the attenuator) 

• Waveplate – (already in the attenuator) 

 

3.1. Optics (dis)assembling 
 

In order to get maximum possible attenuation 

polarizer adjustment is necessary. The back cover with 

beam dump can be removed by untightening two 

screws showed in fig. 2. After removing the closure, 3 

microscrews will be uncovered (circled in red). 

Adjusting them while measuring laser power output, 

will allow to reach maximum attenuation.  

 

If necessary, the waveplate and polarizer holder can be 

removed for example for cleaning purposes. To 

remove the waveplate just untighten the retaining ring 

and take out the waveplate. For removing the polarizer 

holder please remove 3 steel screws and carefully pull 

it from the main EO Attenuator body.  

 

 
Figure 1. EO Attenuator operation principle. The intensity of the 

incident beam is varied by means of a K/2 phase waveplate and 

a polarizer. 

 
Figure 2. Disassembly of EO Attenuator. Adjustment microscrews circled in red. To remove the cover loosen two screws on each side of EO 

Attenuator (marked with yellow circle) 
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4. EO Attenuator Software 

Description 
 

4.1. Computer requirements 

 

• Free USB port. EO Attenuator is compatible with USB 

1.1, USB 2.0 and USB 3.0 Computer administrator 

rights (only for installation) 

• Windows XP sp3 (32-bit) 

• Windows Server 2003 sp2 (32-bit) 

• Windows Vista sp1 (32/64-bit) 

• Windows Server 2008 (32/64-bit) 

• Windows 7(32/64-bit) 

• Windows 8(32/64-bit) 

• Microsoft.Net framework 4.0 redistributable (installs 

automatically) 

 

4.2. Software installation 

 

1. Check for and download the latest “EO Attenuator” 

software installer package from  

EO LINK here http://.... 

2. Run the downloaded “EOAttenuator-Setup.exe” 

installation file. In case the software is installed on an 

operating system that does not meet requirements, 

only USB drivers will be installed. Click “Yes” to 

continue. 

 

3. Installation window will appear, click “Next” to 

continue: 

 

4. Click “Next”: 

 

5. Select installation directory and click “Next” to begin 

installation: 

 

6. “EO Attenuator” software requires “Microsoft.NET 

Framework 4 Client Profile” or higher version to be 

installed. Setup will offer to download it, choose “Yes” 

if active internet connection is available. Choose “No” 

to download it from www.microsoft.com/en-

us/download/details.aspx?id=17113 and install it 

manually. One should choose “No” if newer version of 

Microsoft.NET framework is unwanted, or working 
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internet connection is not available. This dialog will 

not appear if framework is already installed. 

Download size is 42 Mbytes. 

 

7. Setup will download “Microsoft .NET Framework 4 

Client Profile”. 

8. After download is finished, “Microsoft .NET 

Framework 4 Client Profile” will be installed, wait for it to 

complete. This can take more than 10 minutes on slower 

machine. 

 

9. Setup will finish by installing drivers. Click “Next” to 

continue:“ 

 

10. Click “Finish” to end installation. The program 

cannot be opened if only drivers were installed (see step 

2 for details). 

 

11.  “EO Attenuator” software icon will appear on “All 

Users” desktop and “All Users” start menu. 

 

12. Connect EO Attenuator to it’s controller. 

13. Connect EO Attenuator controller and PC via USB 

cable. 

14. Plug in EO Attenuator power supply jack. 

15. Windows will detect new hardware. Wait until  

windows configures new device. 
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4.3. Program first run 

 

Launch “EO Attenuator” program using “EO Attenuator” 

icon on desktop or from “Start Menu → All Programs → 

Edmund Optics → EO Attenuator → EO 

Attenuator”. EO Attenuator “Selector” window will 

appear. At least one device must be displayed on the list. 

If the list is empty, please check USB cable, power 

connection. Blue LED must be active if power is OK. Click 

“File → Search For Devices” to refresh. For more 

information about EO Attenuator “Selector” window see 

section” 

EO Attenuator “Selector” window”. 

Select EO Attenuator from a list and click “File → Connect 

Once connected to EO Attenuator, dialog will pop up 

informing that no calibration file is found for new 

attenuator: 

 

 

Select “OK”, calibration window will appear. Use 

instructions in section “Calibration” to setup calibration. 

After calibration is done, “EO Attenuator “control” 

window will appear. Use slider to select and set required 

power. See section “EO Attenuator “Control” window” 

window if more information is needed. 

 

4.4. EO Attenuator “Selector” window  

EO Attenuator “Selector” window contains a list of 

currently connected and powered attenuators. This 

window is used to choose device to work with if there are 

several controllers connected to a single computer. 

Functions of this window are described in the picture 

below. 

 

 

Column description: 

• Name 

It is useful to give meaningful titles for each EO 

Attenuator, if more than one is used in the same 

system. For example, name can be set to “1st 

Harmonic WP”, and another attenuator can be named 

as “2nd Harmonic WP”. New name is saved into 

controller’s internal memory, so new name will be 

maintained on any computer. Name length is 

restricted to 20 characters maximum. EO Attenuator 

can be renamed from “EO Attenuator control” 

window “Options->EO Attenuator Name...” menu 

option. 

• Serial Number 

This column shows unique EO Attenuator controller 

hardware serial number. It is used to identify 

hardware at low level. Serial number must be used for 

hardware identification when contacting the 

developers. 

• COM port 

Each EO Attenuator gets unique serial port name after 

first enumeration with computer. This column shows 

USB-serial port name assigned by Windows.  

• Status 

This column shows “Connected” if attenuator control 

window is active. Otherwise it is blank. 

 

 

“File” menu description: 

• Connect 

 
 

Figure 3. Dialog box, shown if EO Attenuator calibration file is not 

found. 

 

 
 

Figure 4. EO Attenuator “Selector“ window. It is displayed every 

time program is started. There is one device attached to PC in 
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Opens control window for selected EO Attenuator, 

(the same effect as double-click on the device in the 

list. If only one device is connected during program 

startup, control window will be opened 

automatically. See chapter “EO Attenuator “Control” 

window” on page 13 for information. 

• Search For Devices 

Starts searching for EO Attenuator devices attached to 

computer. It can help if not all devices are detected 

and listed automatically. 

• Close 

Closes EO Attenuator “Selector” window, but leaves 

control windows opened. 

• Exit 

Closes EO Attenuator “Selector” and all control 

windows. 

 

“Help” menu description: 

• User Manual 

Opens user manual 

• About 

Shows software version and contact information. 

 

4.5. Calibration 

 

In order to correctly change the output power, the 

software needs to know the angle of the K/2 waveplate’s 

fast axis. It can be fixed in any angle with respect to the 

rotator. The purpose of calibration is to fix angular offset 

between the K/2 waveplate and the rotator hardware 

zero position. Calibration window is opened 

automatically on first use of EO Attenuator, or can be 

found in menu “Options → Calibration…” in “EO 

Attenuator control” window. Make sure that the 

attenuator is correctly aligned before calibrating. 

 

 

 

Calibration procedure: 

1. Homing. Click “Home” button in section “Step 1” and 

wait till motor stops. This will drive the waveplate holder 

to hardware limit switch (zero position). Step 1 must be 

performed every time the device is turned on or after 

extensive period of usage to eliminate any accumulated 

position error.  

2. At “Step 2” select correct clear aperture (CA) of 

currently connected attenuator. Waveplate CA could be 8 

or 15 mm in diameter. 

3. Rotate waveplate by using buttons in section “Step 

3”, and measure laser power after the attenuator. Numbers 

on the buttons represent motor moving distance 

(expressed in stepper motor steps) and rotation direction. 

One step equals 0.003125. 

Note 

It is advised to search for lowest power (max attenuation) 

position, because usually it can be spotted more easily and 

accurately.  

4. Find minimum or maximum signal power and select 

the appropriate option in “Step 4”. It will be called “Home 

position” in the control window. Angular offset is 

recalculated and shown in “Step 7” field every time “Step 

4” selection is clicked. At this moment, main calibration 

goal is completed and “Apply” button can be clicked to 

 
 

Figure 5. Calibration window. 
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apply changes. Further steps are not mandatory, but 

should be considered for convenience. 

5. Calibration result can be verified by using 

buttons in “Step 5” panel. Usage example: click “Drive 

to minimum power” button and wait till the rotator 

stops. Use buttons “-0,01” and “0,01” (located in “Step 

2”) to ensure if current position is really of lowest 

power. If it is, click “Apply”, else select “Minimum 

power” in “Step 4” again, to redefine offset. The same 

can be done with maximum power point.  

6. Alignment of the polarizer and waveplate is 

critical for ensuring optimal performance, thus during 

the calibration EO Attenuator should be aligned to 

reach maximum performance. Real maximal and 

minimal transmitted power should be obtained by 

adjusting the polarizer with adjustment microscrews 

in the motorized attenuator (figure 2). Once 

measured, these extreme values should be entered in 

relevant fields of “Step 6”. Usage example: one uses 1 

W laser, and 20 mW is measured as minimal power, 

and 0.99 W as maximal power. In such case firstly “Use 

absolute power measurement units” should be 

checked, then value “0.02” should be entered into 

field “Minimum measured value:”, and “0.99” – into 

“Maximum measured value:”, and “W” should be 

enreted into “Enter measurement units to use:” 

textbox, because measurement units are “Watts”. 

7. Click “OK” button to accept calibration or 

“Cancel” to discard. If dialog, window-request go to 

zero position will appear, click “Yes” for correct device 

operation. 

 

4.6. EO Attenuator “Control” window 

 

EO Attenuator “Control” window is used to change laser 

power after EO Attenuator attenuator. Main components 

of this window are described below. 

• EO Attenuator name and serial number is shown on 

each attenuator control window caption. Serial 

number is unique for each EO Attenuator controller 

and cannot be changed as it is used to identify 

hardware at low level.  

• Power meter panel always shows existing power 

after the attenuator. Percentage range is from 0 % to 

100 % of transmission. Zero percent means that 

waveplate occurs at 45 degrees angle, beam 

polarization is rotated by 90 degrees and is maximally 

attenuated. Display reading “100%” means that 

waveplate is rotated at minimum attenuation – 

maximum transmission angle. 

 

If “Use absolute power measurement units” checkbox 

is set in “Options → Preferences” or during calibrating, 

numeric display, showing “mW” becomes active. 

Absolute power reading is converted from percentage 

value with respect to minimal and maximal measured 

power using power meter. Correct min and max 

power values must be set in program preferences or 

calibration windows. 

• Lower slider changes power from 0 % to 100 % with 

resolutuion of 0.25%. Values in lower numeric fields 

will alter according to slider position. There is a 

triangle-shaped marker above lower slider which 

shows current power setting, which serves as 

convenient reference for slider usage. 

• Enter required value (%) field is used to manually 

enter percentage of EO Attenuator transmission. 

Decimal point symbol is “.” (dot), two decimal places 

can be used. Valid range is 0.00 % .. 100.00 %. 

• Absolute required power field is available if “Use 

absolute power measurement units” option is set in 

“Options → Preferences…” or “Options → 

Calibration…”. Decimal point symbol is “.” (dot). Valid 

 
 

Figure 6. Power meter panel: right - “Use absolute power 

measurement units” checkbox is set in “Options → Preferences”, 

left - checkbox is unset. 
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range is from “Minimum measured value” to 

“Maximum measured value” set in program 

preferences. 

• Preset buttons can be used to quickly set discreet 

values of output power if absolute value was 

predefined in calibration stage. Left click on any of 

them and appropriate value will appear in (4) or (5) 

text boxes.  

 

“GO” button. Click to set power (rotate waveplate). 

Note 

If “Automatically execute “GO” after required power 

change” is selected in “Options → Preferences” 

waveplate would rotate automatically after any of 

aforedescribed power control option is used (button 

pressed, slide moved, power value enteres, etc. 

Otherwise click “GO” button to actually set power 

• “STOP” button cancels rotation. 

• Buttons “<<” and “>>” will continuously 

decrease/increase power. Controller firmware must be 

up to date for these buttons to appear.  

• “Home” button will drive waveplate rotator to home 

limit switch and back to “Home position”, set in 

“Options → Preferences…”. Usually this should be 

executed every time when device is turned on. 

 
Figure 7. “Edit Preset Buttons at Preferences” window. Currently preset 

values are 0%, 25%, 50%, 75%, 100% of transmission, because checkbox 

is unchecked. Otherwise all values would represent absolute power in 

user selected units. 
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Figure 8. EO Attenuator “Control” window. Currently laser power is set to 375 mW or 75 % of full calibrated range. Measurement units are 

available because absolute minimal and maximal power values are set in program preferences during calibration process. 
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“File” menu description: 

• Save Calibration… 

Current program settings can be saved to file. Configuration file includes all options in “Options → Preferences”, 

preset values and calibration offset. Run time program configuration files are saved in folder 

“AppData\Local\Temp\EO_temp\”. 

• Load Calibration… 

Program settings can be restored from file. Configuration file includes all options in “Options → Preferences”, 

preset values and calibration offset. Current configuration will be overwritten. 

• Show Device Selector 

Opens EO Attenuator “Selector” window. 

• Close This Window 

Disconnects from EO Attenuator and closes active “Control” window. 

“Options” menu description: 

• Calibration… 

Opens EO Attenuator calibration window. See chapter “Calibration” on page 12 for details. 

• Preferences 

Opens program configuration window. See chapter “Program preferences description” on page 15 for details. 

• EO Attenuator Name… 

• Opens “Rename Device” window. Use up to 20 characters for name. Enter new name and click “OK” to accept. 

 

 

 “Help” menu description: 

• User Manual 

Opens user manual. 

• About… 

Shows software version and contact information. Please include software version and controller serial number when 

contacting manufacturer. 

 

 
 

Figure 9. “Rename Device” window. 
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4.7. Program preferences  
 

Preferences window can be accessed by “Options → Preferences” menu item in EO Attenuator control window. 

 

4.7.1 GUI input method options 

• Set power on ”Enter” key press and preset button click. If checked, the power value will change by clicking “Enter” 

key after entering a required value. 

• Set power when mouse leaves trackbar. If checked, the power value will change when mouse leaves the trackbar. 

• Set power in realtime when sliding trackbar. If checked, the power value will change while sliding the trackbar. 

 

4.7.2 Controller buttons. Speed of attenuation 
 

Start rotate with low speed 

In this section rotation speed of attenuator could be easily changed by using a slider “…”  (see Figure 10). Speed: 

 Minimum speed is 0,004 steps/s. 

 Maximum speed is 50 steps/s. 

 

Jump to high speed after 

You can set a time delay in ms for controller to change the speed to fast motion. Time before speed gets higher: 

 Minimum time 0ms. 

 Maximum time 2000ms. 

 

If using a value >0ms it is necessary to set the speed value using a slider of High speed.  

 

 
 

Figure 10. Program preferences window. Can be found under menu “Options 

→ Preferences”. 
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While using this option (value is >0ms) it is more accurate and easier to set the right value of attenuation when using 

buttons on a controller Left/Right or Min/Max (Figure 13). The rotator firstly will move with speed of “Start rotate with 

low speed” value, after set time it will start to move faster with set “High speed” value. 

 

Note: 

“Automatically execute “GO” after required power change” must be checked for this options to be enabled. 

• Use absolute measurement units for preset buttons. If this is set, preset button values are shown as absolute 

power values, otherwise, preset button values mean percentage (%) of transmitted power. Option “Use absolute 

power measurement units” must be set for this option to be enabled (see in calibration). Preset button values are 

recalculated automatically with respect to min and max measured power. 

 

4.8. Red error signs in control window 
 

Red error signs are dislplayed in control window: 

 

• HOME! 

Device is not homed after power on, so there is no accurate position reference point for the waveplate. Ratio readings 

are inaccurate, so ratio change is prohibited. Execute homing first (hold MIN/MAX buttons for 5sec or push home 

button in control window) 

• ALARM! 

Impossible to move motor - hardware error. Please check wiring, overheating, power supply.  

• CRC! 

Controllers calibration/settings are corrupt. Data corruption can occur due to power supply loss during calibration 

process. Please run calibration process. 

  

 
 

Figure 11. EO Attenuator “Control” window with error signs (Home 

Alarm, Crc). 
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5. EO Attenuator Controller 

Hardware 
 

5.1. Controller specifications 
 
EO Attenuator controller is bipolar stepper motor 

driver withspecifications listed in Table 1 below. 

Table 1. Controller specifications 

Characteristic Rating 

Max output 

voltage 
+12 V 

Max output 

current 
2 A 

Current 

regulation type 
Pulse Width Modulation 

Microstepping 

capability 
Steps 1/256 

Position 

feedback 

Open loop operation (no 

external position feedback 

encoder) 

Controller 

protection 

Driver have overheating and 

over current (2A) protection 

Device can be 

operated by 

Computer software via USB 

port 

Limit switch 

One limit switch can be 

connected and used only for 

homing 

Connector 
7 pin circular connector, 712 

series 

 

5.2. Controller usage 
 

BACK VIEW 

The following connections are situated in the back 

of EO Attenuator controller: power jack (12V), and 7 

pin circular connector (712 series) for EO Attenuator 

(Figure 12). 

 

 

TOP VIEW 

There are two buttons in the top of the EO Attenuator 

controller: MIN and MAX.  

 MIN – while holding turns the waveplate to a 

minimum attenuation. 

 MAX – while holding turns the waveplate to a 

maximum attenuation. 

 HOME - holding both MIN/MAX buttons for 5sec. 

moves attenuator to home position. 

There are 4 LED indicators: 

 Power – indicates power from USB connection 

with PC. 

 Status: 

o If blinking slowly (1 blink in 1 sec.) – need 

homing; 

o If blinking fast (3 blinks in 1 sec.) – the 

waveplate is rotating; 

o If iluminating continiously – EO 

Attenuator is homed, the movement is 

stopped. 

 MIN – the EO Attenuator is at it‘s minimum 

attenuation; 

 MAX – the EO Attenuator is at it‘s maximum 

attenuation. 

There is port for a USB cable. 

  

 
Figure 12. Back view of EO Attenuator Controller. 
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6. Main dimensions 
 

6.1. EO Attenuator 
 

 

 

6.2. EO Attenuator Controller 
 

 

 
  

 
Figure 12. Main dimensions and mounting options of EO Attenuator. 

 
 
Figure 12. Main dimensions of EO Attenuator controller. 
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